Transcription

Technical BulletinIssue DateFebruary 6, 2004Metasys System Extended Architecture GraphicsStencil Library (GSL)Metasys System Extended Architecture Graphics Stencil Library.3Introduction. 3Key Concepts. 4Graphics Stencil Library Overview . 4System Requirements . 4Scalable Vector Graphics. 4Microsoft Visio Professional 2002 . 4Templates and Stencils. 5The Template Library . 5Shapes . 6User Graphics Tool . 7GNU Zip (gzip) . 8Drawing and Template Layers . 8Special Shape Functions . 9Aliases. 9Detailed Procedures. 10Installing the GSL. 10Using the GSL in Visio 2002 . 11Using the Hide Label and Hide Value Boxes Functions. 14Importing an AutoCAD File for Use as a Floor Plan Graphic . 17Modifying an Imported AutoCAD File for Use as a Floor Plan Graphic. 22Creating a Floor Plan Graphic from an AutoCAD File - Alternate Method . 26Importing SVGZ Files to the User Graphics Tool (UGT) . 27Binding Data to a Metasys System Extended Architecture Graphic Using the UGT. 34Editing, Copying, and Pasting a Metasys System Extended Architecture Graphic ValueBox Format. 39Implementing Aliasing . 42 2004 Johnson Controls, Inc.Code No. LIT-1201641www.johnsoncontrols.comSoftware Release 1.1

2Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical BulletinTroubleshooting . 53Limitations . 53Tips on Improving Performance When Using the GSL . 54

Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin3Metasys System ExtendedArchitecture Graphics StencilLibraryIntroductionThis document describes the GSL and how to use the GSL to makebackground drawings for Metasys system extended architecturegraphics.This document describes how to: install the GSL use the GSL in Visio 2002 use the hide label and hide value boxes functions import an AutoCAD file for use as a floor plan graphic modify an imported AutoCAD file for use as a floor plan graphic create a floor plan graphic from an AutoCAD file - alternatemethod import SVGZ files to the User Graphics Tool (UGT) bind data to a Metasys system extended architecture graphic usingthe UGT edit, copy, and paste a Metasys system extended architecturegraphic value box format implement aliasingIn addition this document provides information on the limitations ofthe GSL and on improving performance when using the GSL.

4Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical BulletinKey ConceptsGraphics Stencil Library OverviewThe Metasys system extended architecture Graphics Stencil Library(GSL) is a set of Visio Stencils, Templates, and add-ons (includingGzip, a compression utility), used with Microsoft Visio Professional2002 to create graphics for use in your Metasys system. Use the GSLto create Visio Extensible Markup Language (XML) drawing files(VXD) that the GSL then allows you to convert to SVGZ. The SVGZfiles created with the GSL in Visio 2002 are then imported into theUser Graphics Tool (UGT) in the Metasys system extendedarchitecture. The templates included in this library are listed inTable 1.System RequirementsTo install the GSL successfully, your computer must be runningWindows 2000 Professional with Service Pack 3 (SP3) orWindows XP with SP1, Java Runtime Version 1.3.1, and MicrosoftVisio Professional 2002 software.Scalable Vector GraphicsThe Scaleable Vector Graphic (SVG) file format is an XML-basedWeb standard and is viewable and editable within any text editor,much like Hypertext Markup Language (HTML) documents. AnSVGZ file is a compressed SVG file. The World Wide WebConsortium (www.w3.org) maintains the SVG specification. Althoughthe SVG specification defines mechanisms for dynamic and animatedSVG graphics, at Release 1.1 of Metasys system extended architecture,all graphic backgrounds are static images.Microsoft Visio Professional 2002The GSL is designed to work with Visio Professional 2002. At thistime only a few major drawing packages (such as CorelDRAW software and Adobe Illustrator software) support SVG natively.However, Visio Professional 2002 software includes a stencil sheetmechanism that greatly enhances the ease of use of the GSL. For thisreason, an add-on to Visio Professional 2002 software was created thatcan translate Visio Professional 2002’s XML save file format intoSVG XML.Visio Professional 2002 software was selected to improve the speed ofgraphics generation.

Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin5Templates and StencilsThe GSL provides a set of stencils used to create drawings in VisioProfessional 2002. Each stencil consists of a set of related shapes.Several templates (Table 1) are installed with the GSL. Thesetemplates are drawings created in Visio Professional 2002 using thestencils from the GSL. The templates provide a starting point to helpyou create drawings quickly.The Template LibraryThe GSL has Shapes and Templates for common Air, Water and FloorPlan graphics. Table 1 contains a list of the templates installed byGSL.Table 1: GSL Installed TemplatesTemplate Name inVisio SoftwareFull Name of TemplateBase TemplateBase Template.vtxContains only the standard framing forJohnson Controls graphics. All othertemplates are based on this template.Base Water TemplateBase Water Template.vtxUse this template for customer Heating,Ventilating, and Air Conditioning (HVAC)water vtx2StmHXHotWater2StmHXHotWater.vtx3Boiler Hot Water3Boiler Hot Water.vtxComputer Room ACComputer Room AC.vtxFancoilFancoil1.vtxFancoil rk – 50 VAVsNetwork – 50 VAVs.vtxNetwork – EthernetNetwork – Ethernet.vtxNetwork – N2 DevicesNetwork – N2 Devices.vtxOADPOADP.vtxOASPOASP.vtxVAV Dual DuctVAV Dual Duct.vctVAV Dual Duct with ECVAV Dual Duct with EC.vctVAVDual Duct with HCVAVDual Duct with HC.vtxVAV Parallel FanVAV Parallel Fan.vtxVAV Series FanVAV Series Fan.vtxContinued on next page . . .Notes

6Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical BulletinTemplate Name inVisio Software (Cont.)Full Name of TemplateVAV Single Duct with3WHCVAV Single Duct with 3whc.vtxVAV Single DuctVAV Single Duct.vtxVAV Single Duct with ECVAV Single Duct with EC.vtxVAV Single Duct with HCVAV Single Duct with HC.vtxNotesShapesEach stencil consists of a set of related shapes. Many shapes havebuilt-in labels. These labels have a control handle (the control handleappears as a yellow diamond when a shape is selected [Figure 1]) tomove them around the page.Figure 1: Label Handle on a ShapeSome stencil shapes have custom properties and entries on theirright-click menus. The label text can generally be set using one of thecustom properties (Figure 2).Figure 2: Custom Properties on a Sensor

Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin7User Graphics ToolThe Metasys system extended architecture includes a User GraphicsTool (UGT) that accepts SVGs, SVGZs, or Joint Photographic ExpertsGroup (JPG) files for background images.Graphics provide a visual representation of the monitored systems.They enable you to quickly check the status of systems and recognizeunusual conditions. You can design graphics to allow you to navigatethrough buildings, floors, and other areas, viewing building systemsand control processes.User graphics are usually made up of three parts:Background ImageBackgrounds are static images displayed behind a graphic.Backgrounds can represent buildings, floor plans, mechanicalequipment, and any other image that represents the location orfunction of the equipment in the graphic. A newly-created graphic hasa gray background by default. You can insert a background imageusing a file based on SVG, SVGZ, or JPG graphic formats.You can create SVG background images with graphic drawingpackages or from established libraries of images. We recommendusing Microsoft Visio 2002 software to create background images thatcan be converted to SVGZ format. SVGZ and SVG images must becreated in positive drawing space (quadrant 1, on the positive X andpositive Y axis).Background images in JPG format are usually created with cameras orscanners. You cannot resize a UGT background image in JPG format,and if an area of the graphic’s workspace is not fully covered by theJPG image, the exposed area defaults to gray.SymbolsSymbols are graphic elements or components that are inserted intographics to represent the value or status of equipment in your system.In the UGT’s Edit mode, the symbols appear in a pallet to the left sideof the graphic workspace.HyperlinksHyperlinks allow you to navigate to other graphics and Web addresses.Note:If you are using hyperlinks to Uniform Resource Locators(URLs), you must change a setting in Microsoft Internet Explorer. Inthe Tools menu, click Internet Options . On the Advanced tab, clearthe check box for Reuse windows for launching shortcuts (Figure 3). Ifyou do not clear this check box, the hyperlinked site appears in thesame window as the Metasys software and the back button only takesyou back to the Metasys login screen.

8Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical BulletinFigure 3: Internet Explorer Options - Advanced TabGNU Zip (gzip)GZIP is an open source compression utility included with the GSL tocompress SVG files. The compressed files have the file extensionSVGZ.Drawing and Template LayersAll the templates have a drawing layer and a template layer. Thetemplate layer contains the gray, blue, and black backgrounds as wellas the Metasys logo. The template layer is locked by default to preventaccidental modification. The gray and blue backgrounds are hidden bydefault to display the grid lines. They are unhidden and re-hiddenduring the export process so that they appear in the SVGZ file.Note the following: Visio drawings use points to emphasize that these are not scaleddrawings. The Page size is 723 x 535 points. This design criterion was madebased on the following assumptions:

Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin -The viewing screen resolution is set to 1024 x 768 points.-A single line Windows operating system task bar is visible.-The user interface window is maximized.-The Navigation Tree is attached and at its full size.9The water side GSL shapes are scaled to snap to a five point grid.All other GSL shapes are scaled to snap to a nine point grid.Special Shape FunctionsMany shapes have special functions that control the appearance of theshape. For example, the temperature element may be selected todisplay either a bulb type element or an averaging type element. Ingeneral, right-clicking on a shape reveals a menu of any specialfunctions available. The most common special function is the PickSensor Type that controls the label text of the shape.AliasesAliases allow a single graphic to be used for multiple typicalmechanical systems. The most common use of aliases is in VariableAir Volume Controller (VAV) graphics. The alias process changes thevalues displayed in the value boxes to represent the particular systemdesired at the moment the graphic is displayed.

10Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical BulletinDetailed ProceduresInstalling the GSLTo install the GSL:Note:Prior to installing GSL, Visio 2002 must be installed on yourcomputer.1. On your install media (Branch Purchase Package), navigate to anddouble-click the GSL.msi file. The GSL setup wizard starts.2. Click Next. The Select Installation Folder screen appears(Figure 4).Figure 4:Select Installation Folder ScreenNote:If you do not want to accept the default folder forinstallation, click the Browse button to choose another folder.3. Select whether the templates should be available to all users of thecomputer or just to you and click Next. The InstallationConfirmation screen appears.4. Click Next to start the installation. When the installation finishes,the Installation Complete Screen appears.5. Click Finish to close.

Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin116. To confirm the installation, start Visio 2002 Professional. TheTemplates folder should now contain folders labeled Air, Network,and Water, which contain the Graphics Stencil Library (Figure 5).Figure 5: Visio 2002 with GSL InstalledUsing the GSL in Visio 2002Note:One of the benefits of using the GSL to create drawings isthat you can find a preexisting template that is similar to the drawingyou want to create. You then modify the existing drawing as needed. Ifyour needs vary a great deal from the existing drawings, use the blanktemplate to create a blank drawing which has all the GSL stencilsavailable, along with the standard Johnson Controls’ templatebackground image.To use the GSL in Visio 2002:1. Start Visio 2002. The Choose Drawing Type screen appears(Figure 6).

12Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical BulletinNote:If the macro security setting in Visio 2002 is set to Medium(default setting), a Disable/Enable Macros message appears every timeyou open a GSL template. Set this option to Low to disable thismessage (Tools Macros Security). Do not leave this setting at Lowif other people use your machine or if this setting violates yoursecurity policies. However, you must enable macros in order for theGSL to function properly.Figure 6: Visio 2002 Choose Drawing Type Screen2. Select a GSL template to start your drawing. A newtemplate-based drawing appears (Figure 7).

Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin13Figure 7: New Template Based Drawing3. Modify the drawing as required by deleting unwanted shapes ordragging other shapes as needed from the stencils that are typicallylocated on the left side of the Visio 2002 workspace.4. To make the generic labels more specific, select the Text button onthe tool bar and click any label you want to change.Note:If you do not change, hide, or delete the labels, they appearin your final drawing as they appear in Visio 2002 software. However,when you bind data to a graphic, you are able to hide labels with data.See the Binding Data to a Metasys System Extended ArchitectureGraphic Using the UGT section in this document. Right-click on thepage background to access master label and value box hide/unhidefunctions. There is also a graphics background hide/unhide function ifyou wish to edit the color of the normally hidden background. To dothis, you also need to unlock the Template layer to select thebackground for editing.5. When you finish modifying the drawing, click the button labeledExport SVGZ on the upper right hand side of the GSL-createddrawing. This button converts your drawing to a compressed SVGfile in the same directory as the drawing from which it is beingexported.

14Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical BulletinNote:If the drawing has not been saved already, select Save As onthe File menu. On the Save As type drop-down list, make sure to selectXML Drawing (*.vxd) and give the drawing a unique name.Using the Hide Label and Hide Value Boxes FunctionsAt Release 1.1 of the GSL, all appropriate shapes have a label andvalue box symbol added to them. These indicators simplify creatingdescriptive text and assist with spacing issues. All labels and valueboxes can be hidden in your graphic either individually or separately.To Hide Labels GloballyTo hide labels globally:1. With your drawing open in Visio Professional 2002, right-click onthe Visio Professional 2002 drawing without selecting any shapes.The right-click menu appears (Figure 8).Figure 8: Visio 2002 Right-Click Menu2. On the right-click menu, select Hide Labels. All labels and setpointdescriptions in your drawing are hidden (Figure 9).

Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin15Figure 9: Labels and Setpoints Hidden GloballyHiding Value Boxes GloballyTo hide value boxes globally:1. With your drawing open in Visio Professional 2002, right-click onthe Visio Professional 2002 drawing without selecting any shapes.The right-click menu appears (Figure 8).2. On the right-click menu, select Hide Value Boxes. All value boxesare hidden (Figure 10).Note:If you hide the value boxes before exporting an SVGZ file,you do not have to cover Visio value boxes exactly with Metasyssystem extended architecture value boxes.

16Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical BulletinFigure 10: Value Boxes Hidden GloballyHiding Labels and Value Boxes IndividuallyTo hide labels and value boxes individually:In your Visio Professional 2002 drawing, right-click on an individualshape and select Hide Label or Hide Value Box from the right-clickmenu. Only the selected shape’s value box is hidden from the graphic(Figure 11).

Metasys System Extended Architecture Graphics Stencil Library (GSL) Technical Bulletin17Figure 11: Visio 2002 Drawing with Individual Value Box HiddenImporting an AutoCAD File for Use as a Floor Plan GraphicTo import an AutoCAD file for use as a floor plan graphic:1. On the Start menu, select Program Files Johnson Controls GSL GSL Base Template. The GSL Base Template opens inVisio 2002.2. On the Visio 2002 Insert menu, select CAD Drawing. The InsertCAD Drawing screen appears (Figure 12).

18Metasys