Transcription

Tutorial in US and SI UnitsThis tutorial will take you through the process of modeling a small piping system from start to finish anddemonstrate most of the program features. New users are strongly encouraged to run through the tutorial.The tutorial is written with the U.S. customary units shown first followed by the equivalent value in S.I. units.Create and Save a New ProjectIt is recommended that you save your new project as soon as it is created.1. Open the software and create a new project file:a) Click the New File buttonin the Main Toolbar, orb) Go to the File Menu and select New.2. Save the file with the desired name and location:a) Click the Save File buttonin the Main Toolbar or go to the File Menu and select Save orSave As.b) Navigate to the Projects folder and enter North-South Transfer System in the File name field.c) Click the Save buttonto create the project file.Customize the User InterfaceThe User Interface consists of Menus located above the FLO-Sheet, along with Toolbars and Windows thatcan be displayed, hidden, or docked anywhere around the FLO-Sheet.Show and Hide a Toolbar and Window:1. Toolbarsa) In the View Menu, hover over Toolbars and select the Toolbar to display it (checked) or tohide it (un-checked).2. Windowsa) For a Window that is being displayed, it can be hidden from the View Menu or by clicking onon the right side of the Window title bar.b) Alternatively, Right Click on any Toolbar or the title bar of any displayed Window to open adrop down list of all available Toolbars and Windows. Click on the desired Toolbar orWindow to show or hide it.Dock and Undock a Toolbar and a Window:1. Toolbarsa) Click and hold down the left mouse button on the dotted separator line at the beginning of aToolbar.b) Dock the Toolbar by dragging it to the far right, far left, top and bottom of the workspace until ablue rectangle appears to indicate where the Toolbar can be docked, then release the mousebutton to dock it at that location.c) Undock the Toolbar by releasing the mouse button anywhere except on the blue rectangle.

2. Windowsa) Click and hold down the left mouse button on the Message Window title bar.b) Dock the Message Window by dragging it around the workspace until a blue rectangle appearsto indicate where the Window can be docked, then release the mouse button to dock it at thatlocation.c) Drag the Message Window and place it on top of the List View Window to create tabbedWindows. Click the tabs at the bottom to switch between the two Windows.d) Undock the Message Window by clicking on on the right side of the title bar, or by draggingand dropping the Window anywhere except on the blue rectangleAdjust the Size of an Undocked Window1. Undock the Message Window.2. Click on a corner or edge of the Window.3. Drag the corner or edge until the Window is at the desired size.Set up the FLO-SheetThere are several options to determine how the FLO-Sheet will look and what information will be displayed onthe FLO-Sheet.Define the Grid SettingsTo customize how the FLO-Sheet will look:1. Click on an empty space on the FLO-Sheet.2. In the Property Grid, click the triangle beside Grid Settings and set the following:a) Grid Type: Orthogonal (the other option is Isometric)b) Grid Spacing: Fine (the other options are Standard and Coarse)c) Show Grid: check the box to show the gridd) Snap to Grid: check the box to snap to gridSet the Device View Options1. To customize the amount of information to display on the FLO-Sheet for each Device: Click on anempty space on the FLO-Sheet.

2. In the Property Grid, click the triangle beside Device View Optionsa) Expand the section for each Device, then expand the FLO-Sheet Text and check the selectionbox for each parameter to display.b) Expand the Valve and Fittings Symbols section and check the box beside all the types todisplay on the FLO-Sheet.Define the Authorship Settings

1.2.3.4.In the Property Grid for the FLO-Sheet, click the triangle beside AuthorshipEnter your Company nameEnter the following Project name: North-South Transfer SystemEnter your name as the AuthorDefine Calculation Settings1. In the Property Grid for the FLO-Sheet, click the triangle beside Calculation Settings.2. For the Calculation Method select Darcy-Weisbach (other option is Hazen-Williams).3. Leave the following settings at their default values. These can be changed if the software cannotconverge to a solution.a) % Tolerance: 0.01%b) Max Iterations: 100c) Linear Switch Point: 10%d) Laminar Cutoff Re: 2100e) Force Laminar Calculations: UncheckedDefine the Document Units

The project Document Units are used as the default units for the displayed results on the FLO-Sheet, thecalculated results in the Property Grid, and the user-entered Design Data for all Devices in the PropertyGrid.Define the Document Units:1. Click the System Menu and select Units to open the Adjust Document Units dialog box.2. In the Adjust Document Units dialog box:a) Set the Pressure Reference to gage.b) Clickto open the Calculate Atmospheric Pressure dialog boxi.Enter an Elevation of 500 ft (152 m)ii.Clickto close the dialog box.iii. Review the calculated value of Atmospheric Pressure.iv.Over-ride this value by entering 14.7psia (101 kPa).v.Note that the unit for Atmospheric Pressure can be changed with the drop down menu.c) Select Volumetric as the Flow Rate Type

d) Clickto open the Custom Units dialog box.i.Enter Smoot 3/sec in the Unit Label field for a custom Volumetric Flow Rate.ii.Enter 2.38e8 for the Conversion Factor.iii.iv.Clickto close the Custom Units dialog box.Click the drop down menu of the Volumetric Flow unit and scroll down to see that theCustom Unit is now available to choose from.v.Select gpm for the Volumetric Flow rate unit.3. Click the drop down menu for a list of available units for each quantity. Accept the default units at thistime.4. Clickto close the Adjust Document Units dialog box.Define a Fluid Zone

Fluid Zones provide key fluid property information for calculations throughout the model.1. Click the System Menu and select Fluid Zones to open the Fluid Zones dialog box.2.3.4.5.6.7.Clickto open the Fluid Properties dialog box.Enter Water at 60 F and 75 psig (Water at 15 C and 517 kPag) in the Fluid Zone Name field.Select Table Fluid as the Type (other option is Custom Fluid)Scroll down the list of Installed Fluid Tables and select Water.Specify 60 F (15 C) in the Temperature field.Specify 75 psig (517 kPa) in the Pressure field.a) The software calculates the remaining fluid properties using the formulas in the Fluid Table.b) Note the values of Density, Viscosity, Vapor Pressure, and Critical Pressure (Specific HeatRatio and Relative Molecular Mass are calculated if the fluid is a gas or vapor.)8. Clickto close the Fluid Properties dialog box9. Clickto close the Fluid Zones dialog box.

Define a Pipe SpecificationPipe Specifications are used to define the pipe material, schedules, pipe sizes, the valves and fittings ValveTable, and the pipe Sizing Criteria and Design Limits.1. Go to the System menu and click Specifications to open the Pipe Specifications dialog box.2.3.4.5.Clickto open the Pipe Properties dialog box.Type Steel Sched 40 in the Name field.Scroll down the list of the Installed Pipe Tables and click the arrow next to Steel A53-B36.10.Scroll down and select 40 from the list of available schedules.a) Note the values of Absolute Roughness and the Hazen-Williams C Factor are default valuestaken from the Steel A53-B36.10 Pipe Table and can be over-ridden if desired.b) Note the displayed Size Range for the Pipe Material and Schedules.

6. In the Sizing Criteria drop down list:a) Select Design velocity (other options are Head Loss per 100 units of length or Pressure Dropper 100 units of length)b) Specify 8 ft/sec (2.4 m/s) in the Velocity field7. In the Design Limits fields:a) Specify 0 and 12 ft/sec (0 and 3.7 m/s) in the Velocitymin and max fields (respectively).b) Specify 0 and 285 psig (0 and 1965 kPag) in the Pressuremin and max fields (respectively).c) Specify 4000 in the Reynolds No min field and leave the max field blank8. Open the drop down menu for Valve Table and review the available Valve Table to choose from.Select the StandardValve Table.9. Clickto close the Pipe Properties dialog box.10. Clickto close the Pipe Specifications dialog boxDraw the Piping System ModelThe PIPE-FLO Interface allows the piping system model to be drawn quickly by placing all the Devices onthe FLO-Sheet without entering any Design Data. A default Device Name is automatically entered andincremented to create a unique name for each Device. The user can over-ride these names and enter theirdesired name when entering the Design Data.Alternatively, the user can draw each Device and then immediately enter the Design Data before addinganother Device.

The following procedure will have you draw the system first, then go back and enter the Design Data.Place All Devices on the FLO-SheetSelect the following Devices in the Toolbox window and place them on the FLO-Sheet roughly locatedaccording to the image:1. A Tank on the FLO-Sheet2. A Sizing Pump3. A Curve dP Device4. A Flow Demand5. A Pressure BoundaryConnect Devices Together with PipelinesSelect Pipein the Toolbox window and connect each Device together according to the drawing.When the cursor hovers over a Device the Cursor Indicator changes to four green arrows pointing in towardthe Device if the connection is allowed, and to four red arrows if the Device already has the maximum numberof pipes connected and the connection is not allowed.

1. Tank to Sizing Pumpa) Click on the first Tank on the left of the FLO-Sheet.b) Move cursor down and click on a grid line to create a vertex.c) Move the cursor to the right and click on the Sizing Pump to make the connection.2. Sizing Pump to Curve dP Devicea) Click on the Sizing Pump.b) Move the cursor to the right and click on the Curve dP Device to make the connection.3. Curve dP Device to the Nodea) Click on the Curve dP Deviceb) Move cursor to the right and double click to end the Pipe segment and create a Node. (this is anotherway of creating Nodes)4. Connect the Node to the Pressure Boundarya) Click on the Node to start another Pipe and move the cursor up and click on a grid line to create avertex, then to the right and click on the pressure boundary to make the connection.5. Connect the Node to the Flow Demanda) Click on the Node to start another Pipe and move the cursor down and click on a grid line to create avertex, then to the right and click on the Flow Demand to make the connection.NOTE: The Devices and Pipes can be moved around by selecting them and dragging them to the desiredposition.

NOTE: Vertices can be added by holding down the SHIFT key and clicking on a Pipe. The vertex can bemoved to the desired location.Enter Device Design DataDesign Data can be entered individually or multiple Devices can be selected and Group Edited to quicklyenter redundant data.The following steps will guide you through entering the Design Data individually and using the Group Editfeature.Enter the Tank Design DataThe Tank Design Data includes key parameters and the Fluid Zone to use if there are two or more pipes areconnected with different Fluid Zones.Design the Supply Tank1. Select the Tank on the left.2. In the Property Grid:a) In the Name field, enter Supply Tank.b) In the Elevation field, enter 20 ft (6 m).c) In the Surface Pressure field, enter 0 psig (0 kPa).d) In the Liquid Level field, enter 10 ft (3 m).e) In the Fluid Zone field, leave the value set to Undefined (this only needs to be specified ifthe connected Pipes have different Fluid Zones).f) Click in the Penetrations field to activate thebutton to open the Tank Penetrations dialogbox.i.leave the Height set at the default value of 0 ft (0 m).ii.Clickto close the dialog box.3. Notice that the Supply Tank text is now black, indicating that it is fully designed.Enter the Sizing Pump Design DataThe Sizing Pump is used to calculate the Total Head of a Pump based on the hydraulic characteristics of theentire piping system.Design the Sizing Pump1. Select the Sizing Pump.2. In the Property Grid:a) In the Name field, enter Transfer Pump.b) In the Suction Elevation field, enter 0 ft (0 m).c) In the Discharge Elevation field, enter 0 ft (0 m).d) In the Flow Rate field, enter 800 gpm (182 m3/h)

Enter the Curve dP Device Design DataThe Curve dP Device is used to model equipment that has a Pressure Drop that varies with the Flow Ratethrough the equipment, which is the case for many Devices such as heat exchangers, filters, screens, etc. TheCurve dP Device has a Curve Data Estimator to generate a second order curve based on a single user-enteredFlow Rate and Pressure Drop data point.Design the Curve dP Device1. Select the Curve dP Device.2. In the Property Grid:a) In the Name field, enter Duplex Strainer.b) In the Inlet Elevation field, enter 75 ft (23 m).c) In the Outlet Elevation field, enter 75 ft (23 m).d) Click in the Curve field to activate thebutton. Click onto open the Curve Data dialogbox.i.The default units displayed come from the Document Units but can be changed ifdesired.ii.In the Description field, enter Clean Strainer.iii.Click on theto open the Curve Data Estimator dialog box.1. In the Static Pressure Drop field, enter 0 psi (0 kPa).2. In the Flow Rate field, enter 800 gpm (182 m3/h).3. In the Pressure Drop field, enter 10 psi (69 kPa).4. For the Maximum Flow Rate, enter 1600 gpm (363.4 m3/h).5. Clickto close the Curve Data Estimator dialog box. Notice that thedata table if filled out with values generated using a 2nd order curve.iv.Clickto close the Curve Data dialog box.Enter the Pressure Boundary Device Design DataThe Pressure Boundary is used to model equipment that has a given pressure at the boundary of a system.Design the Pressure Boundary Device1. Select the Pressure Boundary Device2. In the Property Grid:a) In the Name field, enter Pressure Boundaryb) In the Elevation field, enter 85 ft (26m).c) In the Pressure Field enter 75 psig (517 kpa).Enter the Flow Demand Device Design DataThe Flow Demand is used to model equipment that has a given flow requirement at the boundary of a system.The flow requirement can be either flow into the system or flow out of the system that you are modeling.

Design the Flow Demand Device1. Select the Flow Demand Device2. In the Property Grid:a) In the Name field, enter Flow Demandb) In the Elevation field, enter 45 ft (14m).c) In the Flow Rate field, enter 100 gpm (23 m3/h).d) In the Flow Type field, select Flow Out.Enter the Node Design DataNodes provide a location for connecting multiple Pipelines together and for providing a point in the systemwhere the Pressure is calculated, making them useful for identifying the location of pressure gages in thepiping system.Design the Nodes1. Select the Node at the outlet of the Duplex Strainer (Curve dP Device)2. In the Property Grid:a) In the Name field, enter PG-101.b) In the Elevation field, enter 0 ft (0 m).Enter the Pipe Design DataThe Pipe Design Data includes key pipe and fluid properties and the ability to add valves and fittings that areinstalled in the Pipe. There are also options to Close the Pipe to simulate a closed valve.A Pipe Size Calculator is available to size the Pipe based on a Sizing Criteria that is selected in the PipeSpecification.Design the Pump Suction Pipe1. Select the Pipe between the Supply Tank and Transfer Pump2. In the Property Grid:a) In the Name field, enter Suctionb) In the Fluid Zone field, select Water at 60 F and 75 psig(Water at 15 C and 517 kPa) fromthe drop down listc) In the Specification field, select Steel Sched 40 from the drop down listd) In the Size field, click the button to open the Pipe Size Calculatori.In the Design Flow Rate field, enter 800 gpm (182 m3/h)ii.The Calculated Size that will be closest to the Sizing Criteria is displayed (6 in) (or 150mm).iii. From the drop down list, choose 8 in(200 mm) instead since this is the pump suctionpiping (and we want to maximize NPSHa).iv.Clickto close the Pipe Size Calculator.e) In the Length field, enter 45 ft (14 m)f) In the K (Valves & Fittings) field, click thebutton to open the Valve and Fittings dialogboxi.Expand the Fitting section:

1. Select Entrance - Sharp Edged and clickInstalled listii.iii.iv.v.2. Select Elbow - Standard 90 , enter 3 for Count, then clickplace them on the Installed listExpand the Valve section and add 2 Gate valves individually:to place it on theto1. Select Gate - Knife, leave the Count as 1, then clickon the Installed listto place it2. Select Gate - Knife, leave the Count as 1, then clickon the Installed listto place itClickto close the Valve and Fittings dialog box.Notice the calculated K (Valves & Fittings) which is the sum of the ResistanceCoefficients for all the installed Valves and FittingsNotice that the Suction Pipe shows the individual gate valves, but there is only onesymbol representing all 3 elbows. The symbols can be moved along the Pipe forgraphical purposes, or using the Device View Options the Valves & Fittings can behidden.Group Edit Common Fields on the Remaining Pipelines3. Select all the Devices by Left Clicking above and to the right of the North Tank, holding downthe Left Click and dragging the cursor to the bottom left of the FLO-Sheet (this draws a selection boxaround all of the Devices), then releasing the Left Click. All the Devices will be selected and theProperty Grid will display an expandable list of the Device types.4. In the Property Grid, expand the Pipe Design section5. In the Fluid Zone field, select Water at 60 F and 75 psig(Water at 15 C and 517 kPa) and then clickoutside the field.a) Notice that when all selected devices have the same value, it is displayed in the field.6. In the Specification field, select Steel Sched 40a) Notice that the field now says Steel Sched 40. This allows the Pipe Size to be Group Edited aswell. We'll come back to this below.7. Group Edit the Names of the remaining Pipes:a) With all the Devices selected, de-select the Suction Pipe by holding down the CTRL key thenclicking on the Suction Pipe.b) In the Name field, enter 10-TW-1, then Enter.c) Notice that all the selected Pipes take the new Name format, but the last number is incrementedby 1 to create a unique name for each Pipe.8. Group Edit common Pipe Sizesa) Click on an empty space on the FLO-Sheet to de-select all the Devicesb) Hold down the CTRL key and select Pipes: 10-TW-1, 2, 3 and 4c) In the Size field of the Pipe Design section of the Property Grid, select 6 in (150 mm), thenEnterd) Notice that these four Pipes now show that they are 6 inch (150 mm)

Enter the Remaining Design Data for the Pipes1. Using the table below, enter the Lengths and Valves & Fittings for the remaining Pipes.Calculate the ModelNow that all the Devices in the model have the required Design Data, the system can be calculated and theresults evaluated for each Device and the entire system. The results can be evaluated using the informationselected for display on the FLO-Sheet and in the List View Window, but the first results that should beevaluated are any Messages that are generated in the Messages Window.Calculate the model by either:1. Click the Calculate buttonon the View Toolbar, or2. Select Calculate from the System Menu, or3. Click F5.To clear the results, clickagain, F5, or select Calculate from the System Menu again.Evaluate MessagesThere are five (5) levels of messages based on the calculated results. Level 0 messages are generated if resultscannot be calculated based on how the system is designed. Level 1 messages mean the results are invalid, Level2 indicated increased uncertainty in the results, Level 3 messages are generated if user-entered limits areexceeded, and Level 4 are informational messages about the status of devices.To view the Messages:

1. If the Message Window is not dis