Transcription

Lesson 3: The LibreOffice Drawing Tools3THE LIBREOFFICE DRAWING TOOLSLEARNING OUTCOMESIn Lesson 2 you learned how to work with a longer document (the Term Paper). You practicedinserting page numbers, formatting text, using the indent markers, creating sections and columnsof text, finding and replacing text, moving and copying text, and putting borders around blocks oftext. You also learned how to create a list, such as a Table of Contents, with dot leaders to connectthe eye visually to the items in the list.After completing lessons 1 and 2, you should be beginning to think of yourself as reasonablyproficient at word processing, but there is still much to learn. In this tutorial you will be introducedto features of LibreOffice that are especially useful when working with images (pictures, charts,and so forth)The set of LibreOffice drawing tools that are accessible from within Writer, and that aretherefore useful for annotating and/or illustrating ideas expressed in a writing assignment, areextensive, easy to use, and powerful in the sense that they enable anyone to create good qualityimages or designs for a multitude of practical applications. Teachers, in particular, shouldfamiliarize themselves with these drawing tools, not only for their own purposes, such as thepreparation of handouts for class, but also so they can introduce the use of the tools to theirstudents. Thus the students, too, will use them in the completion of project work of all kinds.Lesson 3 thus will cover the following: The tools available for drawingDrawing, moving, rotating, resizing, and otherwise editing simple shapes and linesAutoShapesSelecting one or more objects at once—overlapping, ordering, aligning, and rotatingobjectsUsing colors, patterns, and other visual effectsGrouping and ordering objectsFontworkA caveat before you begin: You'll find it easiest to use the tutorial if you follow the directionscarefully. On computers there are always other ways of doing things, but if you wander off onyour own be sure you know your way back!3.1 GETTING STARTEDThis tutorial is designed to give you practice working with the drawing tools that are built into thevarious LibreOffice applications. Drawings that you create in one LibreOffice application such as77

ESSENTIAL LibreOffice: Tutorials for TeachersCopyright Bernard John Poole, 2016. All rights reservedDraw can be easily copied and pasted into other LibreOffice applications, such as Writer, Impressor Calc.The only way to learn the skills required to get the most out of the drawing tools is to use them.This lesson will get you started in that direction, introducing you to most all the drawing tools andshowing you how to use them. But if you want to become proficient, you will need to work withthem as much as possible (practice makes perfect) and experiment with ideas of your own forapplying the tools in the creation of graphic art work of all kindsPerhaps you already have a natural flair for drawing, in which case you will especially lovethese tools. But even if you think you don’t have a flair for drawing, you may discover, as youbecome adept in the use of the drawing tools, that you have more artistic ability than you everdreamed.One more thing before you proceed. As you work your way through the exercises in this lessonyou will frequently come across tools and skills that are not touched upon here. This is becausethey are beyond the scope of these Essentials tutorials. But if they strike your interest, don’thesitate to check them out; try them and see how much more you can learn.For this lesson it will be useful to have a separate folder, inside your Data Files folder, for allthe drawing-based documents you’re going to create.On your computer, go to your USB drive (Removable Disk) Work Files forLibreOffice 5 Data Files folder, and, in the dialog box, click on New folderand name the new folder Drawing Documents3.2 OVERVIEW OF THE LIBREOFFICE DRAWING TOOLSLet’s start by checking out some of the drawing tools available when you’re using LibreOfficeWriter since you are now most familiar with that application. In Writer, the drawing tools areaccessed in the View menu Toolbars option (Fig. 3.1).Fig. 3.1 The Drawing Toolbars in Writer78

Lesson 3: The LibreOffice Drawing ToolsBear in mind that none of these tools are difficult to use once you become familiar with them.Anyone, especially teachers, will find them invaluable for many, many applications in and out ofthe classroom. Your students will love them, and love you for encouraging them to learn how touse them.Working with Shapes and LinesIf you are drawing shapes and lines you’d use the tools in the Drawing toolbar (Fig. 3.2), whichare accessed from the View menu Toolbars Drawing tools.Basic Shapes and linesSymbol, Block Arrow, Star, Callouts, Flowchart, Text Box & FontworkFig. 3.2 The set of lines and basic shapes in the Drawing toolbarAside from basic shapes and lines, the Drawing toolbar provides Symbol, Block Arrow, Star,Callout, flowchart, Text Box, and Fontwork shapes.In order to work with those lines and shapes—change the color of a line or border or the areastyle or fill of a shape, or rotate the shape, and so on—you would use the tools in the DrawingObject Properties toolbar (Fig. 3.3), also accessed from the View menu Toolbars option.Fig. 3.3 Working with existing shapes and lines in the Drawing Object Properties toolbarGrouping and Aligning objects on the pageWhen using the drawing tools to create shapes and other objects, you may well want to align someor all of them and perhaps group them together so that they become one object. To do this youwould use the Select tool in the Drawing toolbar to select or “gather” the objects you want to grouptogether. Having done that, you would then select from the several alignment tools available in theAlign Objects toolbar to align them according to your design (Fig. 3.4).Fig. 3.4 Aligning selected groups of objects on the pageIf you wanted to convert several objects into a single object, you would use the Group/Ungrouptools to “combine” them as one. This is very useful when you have a complex set of objects(perhaps an architectural drawing, for example) that you need to move around as one unit on thepage, or transfer to another page or another document, and so forth.79

ESSENTIAL LibreOffice: Tutorials for TeachersCopyright Bernard John Poole, 2016. All rights reservedWorking with your own PicturesIf, on the other hand, you are working with a picture that you already have stored on your disk—such as a photograph or a diagram or a chart—you’ll use the Picture toolbar (Fig. 3.5).Fig. 3.5 The set of tools for working with photographs and other prepared imagesThe Picture tools enable you to create watermarks, for example, or convert a picture to grayscale,make adjustments to color density, brightness, and contrast, adjust the transparency of a picture,and rotate and flip an image in various ways.Bullets and NumberingIn Writer you will sometimes have lists of items in your document. If you want to use bullets orhave a numbered list, or if you needed to create different levels, or change the level of a list item;or if you needed to adjust the numbering of the list, you would use the Bullets and Numberingtoolbar (Fig. 3.6).Fig. 3.6 The Bullets and Numbering toolbarFontworkLibreOffice helps you create eye-catching text-based graphics, which can come in handy when youwant to create signs, posters, and displays of various kinds. Again, you’ll find this toolbar, calledFontwork, in the View Toolbars menu (Fig. 3.7).Fig. 3.7 Fontwork toolbar with a Fontwork example3D-SettingsAny shape you draw can be rendered as a 3-dimensional (3D) object, a process called extrusion.Fig. 3.8 shows the 3D-Settings toolbar, also accessed from the View Toolbars menu.Fig. 3.8 The 3D-Settings toolbar with example of an extruded puzzle shape80

Lesson 3: The LibreOffice Drawing ToolsChanging the Page OrientationIn Writer there are two possible orientations for a page—Portrait and Landscape (Fig. 3.10).Fig. 3.9 Portrait or Landscape page orientationLandscape orientation turns the page on its side. This mirrors the orientation of the computer screenand often makes it easier for you when you are working with drawing objects, though there willbe many occasions when you will want to work in Portrait orientation, too. The default pageorientation in LibreOffice is called Page Orientation. You’ll be using Landscape Orientation formost of the exercises that follow. To select one or the other, you’d select Page from the Formatmenu, and in the Page dialog box (Fig. 3.10) you’d click on the Page tab, then in the Paper formatsection click on the radio button to select Portrait or Landscape.Fig. 3.10 Selecting Portrait or Landscape Page Orientation81

ESSENTIAL LibreOffice: Tutorials for TeachersCopyright Bernard John Poole, 2016. All rights reservedUsing the Zoom toolThe Zoom tool lets you zoom in on a page (so you can check out the details) or zoom out (so youcan see the big picture of a page or the document as a whole). While using the LibreOffice drawingtools, you will often want to zoom in on an object you are working on, and it is also useful at timesto zoom out so you can check out the big picture. For this reason it is good to know where to findthe Zoom tools (Fig. 3.11).Grab this little whitecircle with the tip ofthe mouse pointer anddrag it to the right orleft to Zoom in or outon the pageFig. 3.11 The Zoom toolsAs you can see in Fig. 3.11, you can Zoom in and out using the various selections in the Viewmenu Zoom options. Alternatively, you can Zoom in and out very discretely using the sliderin the Status bar at the bottom right of the Writer page (check the second illustration in Fig. 3.11).In the sections that follow, you will practice zooming in and out of the pages you are workingon, and you also will use most of the tools in the various drawing toolbars.Time for you to get to work.3.3 DRAWING, MOVING, ROTATING, RESIZING, AND OTHERWISEEDITING BASIC SHAPES AND LINESYou need a new document for each of the drawing exercises you’ll be completing for the rest ofthe tutorial. This is so that you can share them all with your instructor if required. You’ll save themall in your Drawing Documents folder.82

Lesson 3: The LibreOffice Drawing ToolsStart by opening a new document in WriterClick on Writer Document to open the new document and, in the File menu,select Save As , navigate to your USB drive Work Files for LibreOffice 5 Data Files folder Drawing Documents, name the file Practice Drawing1, and hit SaveLet’s start by learning how to use the basic drawing tools to work with simple shapes and lines.Working with shapesIn the View menu Toolbars click on the Drawing option to bring the Drawingtoolbar onto the bottom of the Writer window (Fig. 3.12)Fig. 3.12 Drawing toolbarLook at the bottom of your Writer screen, which is where the Drawing toolbar is located.Slide your mouse pointer slowly along the Drawing toolbar and read thedescriptions that pop up as you pass over each of the drawing toolsAs you can see, there are dozens of shapes to choose from, including the simplest shapes such aslines, rectangles, ellipses, and freeform lines, which you will practice using in this section of thetutorial. In the next section you will practice using more elaborate (yet still basic) geometricshapes, as well as a variety of symbol shapes, block arrows, symbols for flowcharting (very usefulfor anyone in the management or design fields), callouts, and stars and banners useful for creatingcertificates of excellence, graduation, and so forth. But let’s keep it simple for now.In the Drawing toolbar, locate and click on the Rectangle shape and, usingthe mouse pointer, draw a rectangle of any size (the larger the better) on theWriter pageNow, in the View menu Toolbars click on Drawing Object Properties toopen the toolbar on the bottom of the Writer window (Fig. 3.13)Fig. 3.13 The Drawing Object Properties toolbarBecause the Drawing toolbar and Drawing Object Properties toolbar display at the bottom of theWriter window, it will be easiest to complete the exercises that follow if you zoom out on the page.This will allow you to view the whole page on the screen without the toolbars limiting your view.Use the zoom slider in the lower right corner of the LibreOffice window (Fig.3.14) to zoom out to at least 65%Fig. 3.14 The LibreOffice Zoom tool set at 65%83

ESSENTIAL LibreOffice: Tutorials for TeachersCopyright Bernard John Poole, 2016. All rights reservedThere, now you should be able to see the full page. You could, if you wanted to, move the toolbars(by grabbing them on the dotted line at the left edge with the mouse pointer and dragging) to thetop of the window, amongst the other toolbars, or even to either side of the page, but let’s leavethem where they are for now.Notice that the rectangle you drew on the page has a set of handles around it, which allow youto change the shape of the rectangle on the fly by grabbing any handle and dragging on it (Fig.3.15).The handles aroundthe shape appearwhen you select theshape or picture byclicking on it.Fig. 3.15 The set of handles around shapes and other imagesYou’re working with a rectangle, so you won’t need the simple line or arrow tools at the left of thetoolbar. But you may want to have a different size (thickness), color, or style of border on therectangle.With your rectangle selected (it has the handles around it), use the mousepointer to scan the Drawing Object Properties toolbar to check out thevarious tools for working with the Border and Fill of drawing shapes (Fig. 3.16on the next page)Fig. 3.16 The Drawing Object Properties toolbar (annotated)84

Lesson 3: The LibreOffice Drawing ToolsLet’s try out each of these Drawing Object Properties tools now. If necessary, refer to theillustration above (Fig. 3.16) as you complete the exercises that follow.Border Color (not Fill Color)A line or border can be any color. The same applies to the border around a rectangle or any othershape.With the rectangle selected (it has the handles around it), try out some ofthe Line Color options (the first item annotated in Fig. 3.16 above) beforeproceeding with the tutorialBorder StyleA line can be continuous, or it can be dashed or dotted in different ways. The same applies to theborder around a rectangle or any other shape.With the rectangle selected (it has the handles around it), try out each of theLine Styles (the second item annotated in Fig. 3.16 above) before proceedingwith the tutorialBorder WidthA line can be thick or thin—or even invisible! The same applies to the border around a rectangleor any other shape.With the rectangle selected (it has the handles around it), try out someborder thicknesses (the third item annotated in Fig. 3.16 above) as well asthe 0 (zero) thickness option before proceeding with the tutorialFill ColorThe Fill Color tool lets you choose from a palette of colors for filling a shape with up to 16 milliondifferent colors.With the rectangle selected (it has the handles around it), try some of theseFill Color options (the fourth item annotated in Fig. 3.16 above)Area Style / FillingAs you probably noticed when you checked out the Area tool above, the area of a shape (insidearea, not including the border) can be filled with a range of colors, but it can also be filled withseveral Styles of fill, such as Gradients, Hatching, and Bitmapping (Fig. 3.17).Fig. 3.17 Gradients, Hatching, and Bitmap options for Area Style / Filling85

ESSENTIAL LibreOffice: Tutorials for TeachersCopyright Bernard John Poole, 2016. All rights reservedWith the rectangle selected (it has the handles around it), try out each ofthese Area Style / Filling options (the last item annotated in Fig. 3.16) beforeproceeding with the tutorial; the Gradients are especially interesting—havefun!Save the document (Practice Drawing 1) when you are ready, and Close itWorking with linesYou need a new document for the next drawing exercise, so click on WriterDocument to open a new document and, in the File menu, select Save As ,navigate to your USB drive Work Files for LibreOffice 5 Data Files folder Drawing Documents, name the file Practice Drawing 2, and hit SaveLet's practice drawing different kinds of lines.In the Drawing toolbar (which should be open at the bottom of the Writerwindow) click on the line tool to select it, then use the mouse to draw a straightline anywhere on the page (Fig. 3.18)The handles tellyou that the Lineobject is selected.The larger of thetwo handlesshows the end youstarted at whenyou drew the line.This is thesmaller of the 2handlesLine tool in theDrawing toolbarFig. 3.18 A simple line drawn on the Writer page86

Lesson 3: The LibreOffice Drawing ToolsThe handles tell you that the Line object is selected. If you look carefully, you’ll notice that thetwo handles are not the same size—one is bigger than the other. The larger of the two handlesshows the end you started at when you drew the line. You’ll see the relevance of knowing thiswhen you later want to put arrowheads on the line (explained on page 91—Adding arrowheadsto lines).Now complete the following tasks to learn how to work with different styles of lines.Click anywhere off the line you just drew and notice that the handles (littlesquares) at each end of the line disappear; the LibreOffice Drawing ObjectProperties toolbar also disappears because it is only needed as long as adrawing object is selectedSo You can only edit or move a drawing object of any kind if the handles are showing. Thehandles indicate that the object is selected. Clicking ON the object selects it; clicking OFF theobject deselects it.Click anywhere on the line now, and notice that the handles (little squares)reappear at each end, and both the Drawing toolbar and the Drawing ObjectProperties toolbar reappear, waiting for you to decide what you want to dowith the selected Drawing object (the selected line)Position the mouse pointer anywhere on the line and notice how the cursorchanges to a crosshair (), which tells you that the mouse is correctlypositioned on the line so that when you click the mouse it will allow you to workwith the lineNow, with the handles showing, you can edit the line you just drew.Work your way across the Drawing Object Properties toolbar; try out a fewof the Line Colors, Line Styles, and Line WidthsThese are all the options you have when it comes to a simple line. Take your time; have fun withit and make yourself familiar with the various options available.When you are done checking out the different design options for the line, hitthe Backspace key or the Del key to delete the line from the pageSave the document (Practice Drawing 2) when you are ready, and Close itWorking with rectangles and ellipsesYou need a new document for the next drawing exercise, so click on WriterDocument to open a new document and, in the File menu, select Save As ,navigate to your USB drive Work Files for LibreOffice 5 Data Files folder Drawing Documents, name the file Practice Drawing 3, and hit SaveCreating and editing lines is simple enough. How about shapes such as rectangles and ellipses—or squares and circles?In the Drawing toolbar click on the ellipse (oval) tool, and use the mouse todraw an ellipse (oval) object on the pageNotice the small handles that surround the shape, which you use to change the object’s shape.87

ESSENTIAL LibreOffice: Tutorials for TeachersCopyright Bernard John Poole, 2016. All rights reservedGrab any of the handles and stretch them to change the shape; notice thatthe corner handles allow you to stretch the shape diagonally as well as up,down, left, or right—whereas the handles at the middle of each side onlyallow you to stretch the shape up, down, left, or rightRotating ObjectsTo rotate an object that you have drawn on the screen, you need to use the Rotate t